Prerequisites

Prerequisites

  1. Operation system: Linux, FreeBSD or MacOS
  2. Linux kernel version >= 2.3.32
  3. PHP version >= 5.3.10
  4. GCC version >= 4.4 or Clang
  5. Cmake version >= 2.4 (Cmake is required to compile libswoole as C/C++ library)

Recommend Linux version: Ubuntu 14, CentOS 7 or greater.

PHP version dependency

  1. Swoole only supports PHP version >= 5.3.10, PHP 5.4+ is recommended
  2. Swoole doesn't depend on the extensions like stream, sockets, pcntl, posix, sysvmsg, etc. You simply need to install the basic extensions for PHP.